Skip to content

SheetCam Software Setup Guide

This guide provides step-by-step instructions for installing SheetCam CAM Software. This includes the Avid CNC Mach4 post processor and tool tables for a variety of Hypertherm torches. If you have already installed and licensed SheetCam, skip to Section 3Section 3.



1. Install SheetCam

SheetCamInstall_001


SheetCamInstall_002

  • It is recommended to download "SheetCam TNG Stable version".


SheetCamInstall_003

  • Run the SheetCam TNG installer.


SheetCamInstall_004

  • When you get to the prompt shown above, select the "Create a desktop shortcut" option.


SheetCamInstall_005

  • Select the "Run SheetCam TNG" option and finish the SheetCam install.
  • Continue with the setup and license procedure in the next section.



2. Install License File

Software Setup Note

To complete this section you will need your SheetCam license file. This is provided to you by Avid CNC via email after your purchase of SheetCam. It is recommended to save this file to your Downloads folder or Desktop. If you need to purchase a SheetCam license, they are available at Avid CNC.


SheetCamLicense_001

  • Select your default language.


SheetCamLicense_002

  • Use the "SheetCam TNG setup wizard" to setup SheetCam for plasma cutting.


SheetCamLicense_003

  • After completing the setup wizard, navigate to "Help > Install license file".


SheetCamLicense_004

  • Select your license file and click "Ok".
  • You can now close SheetCam.



3. Install Post Processor and Tool Tables

In this section you will download and install the Avid CNC Mach4 post processor for SheetCam and tool tables for Hypertherm torches. Begin by downloading the installerdownloading the installer for these items. (www.avidcnc.com/support/software/downloads/sheetcam)

SheetCam Usage

If you will not be using the Avid CNC tool tables, you will need to Contact Us for instructions to add the required SheetCam code snippets and path rules.


SheetCamAvidCNC_001

  • Run the "avidcnc-post-and-tools-for-sheetcam" installer you just downloaded.


SheetCamAvidCNC_002

  • Click "Yes" and follow the prompts on the screen to complete the installation.


SheetCamAvidCNC_003

  • Once the finished the installation, open SheetCam.
  • Navigate to "Options > Machine".


SheetCamAvidCNC_004

  • On the "Post Processor" tab, verify "Avid CNC Mach4" is the current post processor.
  • At the bottom of the screen, select "Set custom post options".


SheetCamAvidCNC_005

You will see four different options for customizing the post processor.

  • Distance between references: Distance between pierces where a second probe move (reference) will not take place. The default value of "0" will reference before all pierces.
  • Reference feed rate: Feed rate for probing reference moves.
  • Mechanical switch offset: Applicable only for mechanical touch offs, this is the travel of the switch plunger before the probe signal is activated.
  • Touchoff: Select if mechanical touch off (set value to 0) or ohmic probe touch off (set value to 0) is to be used.


SheetCamAvidCNC_006

  • To load a tool set, navigate to "File > Open toolset".


SheetCamAvidCNC_007

  • Select the appropriate .tools file for your Hypertherm torch model and desired amperage.
  • Within the name of each .tools file is the units, torch model (65_85 is applicable for either 65XP or 85XP), and the operating amperage.


SheetCamAvidCNC_008

  • After selecting your tool set, the "Tools" pane will show a list of possible tools.
  • Double click on one of the tools.


SheetCamAvidCNC_009

  • You will see the tool is pre-populated with the values from the Hypertherm cut charts.
  • At the bottom you will see the "Target Tip Volts". Using the AvidCNC Mach4 post processor, this value will be included in your GCode. Once loaded into Mach4 the target tip volts will automatically be populated when the GCode program is executed.



4. Using Cut Rules


SheetCamAvidCNC_010

  • To open the cutting rules editor press the Cut Rules button on the left of the Tools menu on the left of the SheetCam application window, or use the drop down menu Tools -> Cutting Rules.


SheetCamAvidCNC_011

  • The Path Rules window will then be displayed. The default rule set will have been installed by the "AvidCNC for SheetCam" installer. By default the only path rules which will be enabled turn THC motion off during lead in and lead out moves. To disable or enable path rules click the checkbox to the left of the path rule name.


SheetCamAvidCNC_012

  • To edit a path rule double click on the name of the rule, this will open the rule options. The rule parameters may be edited and saved by clicking "OK." "Start code" and "End code" are the M codes which will be inserted into the g-code program at the beginning and end of the path rule's effect.

  • Additional types of path rules may be implemented by clicking the "Add rule" button at the bottom of the Path Rules editor window.


SheetCamAvidCNC_013

  • While M codes will not show up in the tool preview any path rules which change the feedrate percentage will highlight the effected operations in blue instead of the normal green.